This website requires JavaScript.

在Ubuntu 14.04 和 14.10中将PHP5升级到PHP7

本文主要讲解从PHP5.X升级到PHP7的方法。

一、安装在Ubuntu14.04或14.10中安装PHP7

先添加一个更新源

sudo add-apt-repository ppa:ondrej/php
更新
apt-get update

二、为Apache 服务器更新PHP7.0

Apache执行PHP代码使用的是mod_php模块,安装最新的PHP版本:

sudo apt-get install php7.0

如果你使用的是MySQL数据库,那么你需要执行以下语句同事更新PHP-MySQL的相关绑定。当然你也可以其他有用的模块,比如Curl, GD, Cli, JSON等。
sudo apt-get install php7.0-mysql php7.0-cli php7.0-gd php7.0-json
如果你想安装附加的PHP7.0的一些模块,你可以使用apt-cache命令进行模糊查询。
sudo apt-cache search php7
安装好以后可以重启Apache服务器然后验证php版本
$ sudo service apache2 restart
$ php -v
你也可以放在web目录下进行验证
sudo vi /var/www/html/info.php
如果在web页面上显示的还是5.X那么需要在apache2配置里面禁用php5的模块,然后重新安装下php7.0 (不出意外会自动加载),接着重启Apache2即可 具体可以参考这篇:[Upgrade to 16.04\. php7 not working in browser](http://askubuntu.com/questions/760907/upgrade-to-16-04-php7-not-working-in-browser)

三、参考

How to Install PHP 7.0, Apache 2.4.17, & MySQL 5.6 on Ubuntu 15.10 & 14.04 How to Install PHP 7 for Apache or Nginx on Ubuntu 14.04 and 14.10

0条评论
avatar